Fuse in OSXfuse unable to mount directory without permission

Description

In alluxio, i mounted my s3 bucket as */s3-mnt/ *path. The user and group of the alluxio * /s3-mnt/ * path and its subfolder and files is lu:lu.
My local user group is something like * luuser:lugroup* which is totally different from the user group of the alluxio * /s3-mnt/ * path.

When mounted the alluxio * /s3-mnt/ * path to my local folder through Alluxio-FUSE. The mount process succeeded, but I cannot enter the folder, the console message is permission denied.

If I manually change the user and group of the alluxio * /s3-mnt/ * path to * luuser:lugroup*, the mount will succeed and I can enter the folder and do all the operations that supported in Linux Fuse.

Need to figure out the reason and if it is a bug, try to fix it. If cannot solve, at least document to let user change the user/group and then use Alluxio-Fuse to mount.

Environment

None

Activity

Show:
Lu
October 23, 2018, 11:25 PM
Edited

* When `alluxio.fuse.user.group.translation.enabled` is `false`, the user mounted the Alluxio can access all the files and sub-folders (the user of all files and sub-folders). If `alluxio.fuse.user.group.translation.enabled` is `true`, the user mounted the Alluxio can not access the files and folders that he does not have permission (user group permission will be checked).

Lu
October 26, 2018, 4:24 PM

Not issue

Assignee

Lu

Reporter

Lu

Labels

None

Components

Fix versions

Affects versions

Priority

Major
Configure